Service Updates

This is where we'll let you know about any outages or just provide tips for watching TVNZ

Latest Update: 16 June

FreeviewPlus playback issues

We're currently investigating a number playback issues for OnDemand on specific FreeviewPlus models.

Samsung TV:

We've had reports episodes have been restarting after advertising. For now, we've turned of advertising breaks in episodes as we work to resolve this issue. 

We hope to have a fix in place as soon as possible.

AerialBox T2200:

We're aware content will not play after the first advertisment, but we're confident an upcoming firmware update for the AerialBox will resolve this. 

We're hoping the firmware update for this device will be released by Monday, the 19th of June.

LG:

We're currently working alongside LG to determine a potential resolution for the issue where OnDemand content will not play after the first advertisement finishes. 

We hope to have a fix in place as soon as possible.

 

Specific content like Little Survivor not working on Android devices

We believe that some pieces of extra content, like Little Survivor, are not working on Android devices currently. There may be others extras experiencing the same issue.

Please let us know of any show or episode your Android device isn't able to play, and we'll work on fixing that up ASAP! 

 

OnDemand not working on Windows XP or Vista

Unfortunately, our upgrade to HTML5 from the unsecure Flash means that OnDemand is unable to work on any browser available to Windows XP and Vista users.

Originally, we made the change from Flash to HTML5 with the belief that Firefox v.52 would continue to work for these users. However, this version is missing a key plugin required to access our protected content.

As a result, OnDemand will not work on Firefox for Windows XP and Vista users, and the OS is unsupported by our other supported browser versions.

We deeply apologise for any frustration and inconvenience caused by this decision.

 

Play button frozen/not responding in browser

We have identified that some users are unable to play content on TVNZ OnDemand, with the play button not responding.

We believe this occurs when a user has a VPN or some form of Smart DNS operating in conjunction with their connection, and recommend you deactivate either if OnDemand is not working for you.